Website Home | Info & Posts | Club Membership | Eagle History | Contact Us

eagle will not start

This is a public forum to discuss Eagle related technical issues. If you are having a problem with your Eagle, this is the place to find help.
Re: eagle will not start
Fri Sep 26, 2014 5:35 pm


Ok does the CEL come on and go out it a few seconds if so the ECM is powering up,blowing white smoke you either have air in fuel system or a restriction in the intake have you disconnected the intake at the turbo and tried it ? then it could be the bypass valve on the blower has stuck open but try the 2 easy things first

Are the fuel filters staying full of fuel after trying to start ? I still think it is a fuel problem we just need to figure if the fuel pump is bad or what
User avatar
luvrbus
Club Member
Club Member
 
Posts: 2921
Joined: Mon Oct 13, 2008 12:50 pm


Re: eagle will not start
Sat Sep 27, 2014 3:52 pm


ok the cel goes on and then off. I disconnected the line from the fuel pump discharge side that the goes thru the ecm to the fuel secondary fuel filter. I cranked the motor, should i be getting a constant a fed of fuel there? I am getting fuel pulses not a constant fed. Does this mean I had a faulty fuel pump? I took the air cleaner out and this time shot starter fluid in there for maybe 15 seconds and the engine did fire and run for for maybe 10 seconds.

Can I rig a aux fuel pump to the inlet side of the secondary filer to see if the engine runs? From the secondary fuel filter its feeds to each side of the engine injectors. If so does it matter on the fuel pump pressure? This would tell me for sure if the engine fuel pump is bad.

At this point there maybe an Eagle up for sale :( :( :(

So far $400.00 for 3 group 31 batteries $100.00 for a new fuel primer pump and I think I just about ruined the starter motor from so much cranking. $300 for a starter motor.
eaglebus8920
Club Member
Club Member
 
Posts: 76
Joined: Mon Oct 13, 2008 5:01 pm
Location: St. Louis, MO


Re: eagle will not start
Sun Sep 28, 2014 6:23 am


You need a solid stream of fuel could be a bad hose sucking air causing the pulsing disconnect the supply line from the tank and filter and pressure up with air to check for leaks. The DDEC uses a different high volume pump not like a mechanical engine as it feeds both heads at one time they get weak and will not run.

I hope you don't need a starter but if so buy a 39MT they are light weight,will spin the engine faster on less amps and they are cheaper than rebuilding the heavy ass MT 42 Delcos.We will get it worked out just a minor bump in the road takes a little time, money and patience you know about the money part already :mrgreen:
User avatar
luvrbus
Club Member
Club Member
 
Posts: 2921
Joined: Mon Oct 13, 2008 12:50 pm


Re: eagle will not start
Sun Sep 28, 2014 3:04 pm


OK

The results are in

At some point in time when the Eagle was in the care of the NJT, they installed a 24 volt 9 psi primer pump. The pump ran but not very well. I bought a 12 volt 35 psi primer pump and installed it.

I have the Davoc Fuel Pro 382 installed in the fuel system. I was just about ready to take the engine apart to get to the fuel pump when I thought,, heck just try to prime it one more time and see what happens.. GUESS WHAT?? It fired right up and ran for over an hour with now problems.

While it hat running I ran a check on the system with the Pro Link 9000 reader. No error codes in history or current. I do have a question of the injectors if anyone can chime in on this. The reading of the injectors are below.

1L = 136 ms
3R = 118 ms
3L = 141 ms
2R = 125 ms
2L = 157 ms
1R = 80 ms

Am I seeing that 1R may be weak or clogged as well as maybe 3R. I would think that they all should be close to the same numbers. The engine seems to be running smooth and no smoke what so ever.

Luvrbus thank you so much for all your feed back n help, if there is anything at all that I could help you with please let me know. If you need to the Pro Link reader for your us. I would be more that happy to loan it to you.
eaglebus8920
Club Member
Club Member
 
Posts: 76
Joined: Mon Oct 13, 2008 5:01 pm
Location: St. Louis, MO


Re: eagle will not start
Sun Sep 28, 2014 4:30 pm


Glad you you up and running I would not worry about the injectors for some reason after they been dry it will read like that wait and check it again after running for a couple of hundred mile they will all balance out or quit lol
User avatar
luvrbus
Club Member
Club Member
 
Posts: 2921
Joined: Mon Oct 13, 2008 12:50 pm


Re: eagle will not start
Sun Sep 28, 2014 7:26 pm


I bet Bob Ward will be glad to see you are running. He would be sitting under the pop up covers at the Rally in GI, NE and just say out of the blue I wonder why it wont start? I would say what wont start and he would say of that bus over by St. Louis. So others have been concerned also. We were just out getting ready for corn harvest and just had to watch it. GOOD FOR YOU it runs and look what you now know
LeRoy
User avatar
Liberty
Board Member
Board Member
 
Posts: 371
Joined: Sat Sep 11, 2010 7:09 am


Previous

Return to Eagle Tech

Who is online

Users browsing this forum: No registered users and 1 guest



cron